6.3 System requirements

GeoNetwork can run either on MS Windows, Linux or Mac OS X.

Some general system requirements for the software to run without problems are listed below:

Processor: 2 GHz or higher

Memory (RAM): 1 GB or higher

Disk Space: 200 MB minimum. However, it is suggested to have a minimum of 1 GB of free disk space. Additional space is required depending on the amount of spatial data that you expect to upload into the internal geodatabase.

Other Software requirements: A Java Runtime Environment (JRE 1.5.0). For server installations, Apache Tomcat and a dedicated JDBC compliant DBMS (MySQL, Postgresql, Oracle) can be used instead of Jetty and McKoiDB respectively.

Additional Software

The software listed here is not required to run GeoNetwork, but can be used for custom installations.

  1. MySQL DBMS v5.5+ (All)[2]

  2. Postgresql DBMS v7+ (All)[2]

  3. Apache Tomcat v5.5+ (All)[2]

  4. Druid v3.8 (All)[2] to inspect the database

Supported browsers

GeoNetwork should work normally with the following browsers:

  1. Firefox v2+ (All)[2]

  2. Internet Explorer v6+ (Windows)

  3. Safari v3+ (Mac OS X Leopard)[2]



[2] All = Windows, Linux and Mac OS X


Other documents: The complete manual in pdf format | License | Readme | Changes